「通信」通信達多條件預警設置公式詳細介紹-科技

                                      導讀:本文有1050個文字,大小約為4KB,預計閱讀時間3分鐘 多條件同時預警。 上面已經說了,在預警時雖然選擇了多個條件,但只要其中一個條件達到要求,就會預警,而有時我們需要同時滿足兩個條件時才預警,那怎么辦呢? 這就需要借助通達信的「公式」編輯器...

                                      多條件同時預警。

                                      上面已經說了,在預警時雖然選擇了多個條件,但只要其中一個條件達到要求,就會預警,而有時我們需要同時滿足兩個條件時才預警,那怎么辦呢?

                                      這就需要借助通達信的「公式」編輯器了。按ctrl+F運行「公式」編輯器,把你需要的兩個「公式」都通過修改的方式粘貼出來,再新建一個「公式」,把它們「合并」起來,但最后設置滿足條件時,要把這兩個「公式」結尾部分的條件用and連接起來,保存后,再到預警中設置就行了。

                                      如連續N 日收陽的「公式」

                                      {N為參數:1:10:100)}

                                      UP3:= UPNDAY(CLOSE,N));

                                      與macd線買入

                                      DIFF := EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);
                                      DEA := EMA(DIFF,M);
                                      CROSS(DIFF,DEA);

                                      你合成時,就寫成

                                      UP3:= UPNDAY(CLOSE,N));

                                      DIFF := EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);
                                      DEA := EMA(DIFF,M);
                                      UP3 and CROSS(DIFF,DEA);

                                      就行了,注意最后一句。

                                      三、對于其它非條件選股(包括副圖的一樣「指標」「公式」)的「公式」如「技術」「指標」選股的「公式」,與上面一樣,也應該進入「公式」編輯器中,把這個「技術」「指標」「公式」改編為條件選股「公式」才可以使用。

                                      如副圖中“主力散記籌碼線”「公式」。

                                      原「公式」是:

                                      VAR1:=1;
                                      VAR2:=1/WINNER(CLOSE);
                                      VAR3:=MA(CLOSE,13);
                                      VAR4:=100-ABS((CLOSE-VAR3)/VAR3*100);
                                      VAR5:=LLV(LOW,75);
                                      VAR6:=HHV(HIGH,75);
                                      VAR7:=(VAR6-VAR5)/100;
                                      VAR8:=SMA((CLOSE-VAR5)/VAR7,20,1);
                                      VAR9:=SMA((OPEN-VAR5)/VAR7,20,1);
                                      VARA:=3*VAR8-2*SMA(VAR8,15,1);
                                      VARB:=3*VAR9-2*SMA(VAR9,15,1);
                                      VARC:=100-VARB;
                                      主力: (100-VARA)*VAR1,COLOR0099FF;
                                      「散戶」: MA(WINNER(CLOSE*0.95)*100,3)*VAR1,COLORYELLOW;
                                      新莊: (100-IF(VAR2>5,IF(VAR2<100,VAR2,VAR4-10),0))*VAR1,COLORGREEN,LINETHICK1,POINTDOT ;
                                      VARD:=「散戶」>VAR4;
                                      VARE:=REF(LOW,1)*0.9;
                                      VARF:=LOW*0.9;
                                      VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;
                                      VAR11:=EMA(VAR10,30);
                                      VAR12:=CLOSE-REF(CLOSE,1);
                                      VAR13:=MAX(VAR12,0);
                                      VAR14:=ABS(VAR12);
                                      VAR15:=SMA(VAR13,7,1)/SMA(VAR14,7,1)*100;
                                      VAR16:=SMA(VAR13,13,1)/SMA(VAR14,13,1)*100;
                                      VAR17:=BARSCOUNT(CLOSE);
                                      VAR18:=SMA(MAX(VAR12,0),6,1)/SMA(ABS(VAR12),6,1)*100;
                                      VAR19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
                                      VAR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
                                      VAR1B:=SMA((SMA(VAR1A,4,1)-50)*2,3,1);
                                      VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
                                      VAR1D:=SMA(VAR1C,4,1);
                                      VAR1E:=SMA(VAR1D,3,1);
                                      VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
                                      VAR20:=VAR18<=25 AND VAR19<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR11-CLOSE>=-0.25 AND VAR15<22 AND VAR16<28 AND VAR17>50;
                                      STICKLINE(VARD,VAR4,「散戶」,5,0),COLORWHITE;
                                      STICKLINE(1,新莊,100,1,0),COLORGREEN;
                                      STICKLINE(VAR20,0,80,5,0),COLORRED,LINETHICK3 ;
                                      100,COLORGREEN ,LINETHICK2 ;
                                      0,COLORYELLOW ,LINETHICK2 ;
                                      中線: 15,COLORBLUE ,LINETHICK2 ;

                                      根據使用這的情況得知,當主力線逐漸下移進,該股就會開始拉升,形勢變好。為此可以把這個「公式」改編成這樣一個條件選股「公式」。

                                      VAR1:=1;
                                      VAR2:=1/WINNER(CLOSE);
                                      VAR3:=MA(CLOSE,13);
                                      VAR4:=100-ABS((CLOSE-VAR3)/VAR3*100);
                                      VAR5:=LLV(LOW,75);
                                      VAR6:=HHV(HIGH,75);
                                      VAR7:=(VAR6-VAR5)/100;
                                      VAR8:=SMA((CLOSE-VAR5)/VAR7,20,1);
                                      VAR9:=SMA((OPEN-VAR5)/VAR7,20,1);
                                      VARA:=3*VAR8-2*SMA(VAR8,15,1);
                                      VARB:=3*VAR9-2*SMA(VAR9,15,1);
                                      VARC:=100-VARB;
                                      主力:=(100-VARA)*VAR1;
                                      EVERY(主力

                                      很明顯,因為不需要畫線,也不需要其它函數,所以我只用了原「公式」中前半部分(藍色字體的部分),而修改的也只有后面一句(改編后的紅色字體部分),又加上了一句用來判斷的語句。

                                      保存后就可以在條件預警中使用了。

                                        

                                      通信知識助手總結

                                      上述就是767股票學習網的通信知識助手為您介紹關于「通信」通信達多條件預警設置公式詳細介紹-科技的全部內容,希望對大家有所幫助,另外喜歡我們網站的可以繼續關注其他的股票知識、股票行情、炒股技巧欄目,記得收藏哦!

                                      更多相關文章推薦閱讀

                                    1. 「通信」RSI+BOLL副圖公式源碼 通信達公式編寫
                                    2. 「通達信公式」通達信跟上牛股選公式無未來 通信達公式導入
                                    3. 「通信」通達信CCI反轉選股公式源碼無未來 通信達公式導入-
                                    4. 「通達信指標公式」通信達公式指標大全 2019通達信指標公式
                                    5. 【文章標題】:「通信」通信達多條件預警設置公式詳細介紹-科技 http://www.dirtyearthband.com/gongshi/8118.html轉載請注明出處

                                    6. 您可能還會對下面的文章感興趣:

                                      青青青国产免a在线观看